3. 루비 설치하기


3.1 루비는 어떤 운영체제를 지원하나요?

루비는 Unix/Linux, Mac OS X, 윈도우 95/98/NT/2000/XP, DOS, BeOS, Amiga, Acorn Risc OS, 그리고 OS/2 등을 지원합니다.

루비의 개발은 Linux 환경에서 C 언어로 이루어지고 있습니다.

3.2 루비 소스코드는 어디서 다운로드 받을 수 있나요?

루비의 소스코드는 여기에서 다운로드 받을 수 있습니다. 루비의 현재 릴리즈 버전은 1.8.6입니다. 루비의 최신 개발 버전을 다운로드 받으려면 이곳을 참고하세요.

루비의 패키지 관리자인 루비젬은 이곳에서 다운로드 받을 수 있습니다.

3.3 루비의 컴파일 방법을 알려 주세요.

루비 소스코드를 다운로드 받은 후, 다음의 절차를 따르면 됩니다.

$ tar xzvf ruby-1.8.6.tar.gz
$ cd ruby-1.8.6
$ ./configure --prefix=/usr/local
$ make
$ make test
$ make install
 

루비젬의 설치는 다음 절차를 따르면 됩니다.

$ tar xzvf rubygems-0.9.2.tgz
$ cd rubygems-0.9.2
$ sudo /usr/local/bin/ruby setup.rb
 

3.4 루비를 직접 컴파일 하지 않고 설치할 수는 없나요?

윈도우 사용자는 루비 원클릭 인스톨러를 다운로드 받아 설치하면 됩니다.